目录
- 串口、并口与声卡接口
- 电台接口
- PTT 与 CW 键控的接口
- CW 与 PTT 键控电路
- USB 端口键控
- 并口的其他接口应用
- 外部 DVK 接口
- 频段解码器输出
- 声卡接口
- Windows XP/ Vista/ 7/ 8/ 10/ 11 下的串口与并口接口
- 连接脚踏开关
- 避免 RFI 与其他常见接口故障
- USB 接口设备
- USB 适配器的 CW 问题
- 音频接口与 USB 外置声卡
- 支持的硬件
- N1MM 旋转器控制
设备接口
串口、并口与声卡接口
用于接口的端口
程序可以通过计算机上的若干端口与电台建立接口。这些端口包括:
- 串口——串口可以发送 CW、控制 PTT 或与电台通信;对于某些电台,你可以在一个端口上同时完成这三件事。硬件串口正在从大多数计算机上迅速消失,但如果计算机有空闲的 PCI 插槽,就能买到便宜的串口卡和串口/并口卡。另一种办法是使用 USB 转串口适配器。
- 并口——并口(LPT)接口相当灵活。除了控制 CW 和 PTT 之外,N1MM Logger 还使用 LPT 端口控制常见的 SO2R 控制盒,并把频段信息发给频段解码器,以实现天线或带通滤波器的自动切换。除一个例外,USB 转并口适配器在这里无法使用。另请注意,你仍然需要为电台控制准备一个单独的虚拟或硬件串口,因为电台控制无法通过并口完成。
- USB 端口——现在大多数计算机都有多个 USB 端口。USB 转串口适配器可以提供完整的串口功能,但要注意并非所有这类适配器(或其驱动)都能与 N1MM Logger+ 良好配合。具体信息见 USB 接口设备。还有许多不同的接口设备通过 USB 端口控制来实现各种功能。更多信息见支持的硬件一章。
- 声卡——N1MM Logger+ 可以使用计算机的声卡录制比赛中的 QSO,也可以响应功能键按下,把存储的音频消息发送给发射机。声卡可以是计算机主板上的,也可以是计算机内部的独立板卡,或是通过 USB 电缆与计算机相连的外置声卡。为上述用途,最好找一台具有独立话筒输入插孔、线路输入插孔和线路输出插孔的计算机或声卡。现在有些声卡(尤其是笔记本电脑上的)只有两个插孔,甚至只有一个“复合”插孔,而且输入插孔可能无法在话筒电平和线路电平之间切换。如果是这种情况,你就无法既让话筒经过声卡、又同时录制 QSO。
COM 端口占用错误故障排查
COM 端口占用错误消息——有时 Windows 会混乱,遗弃物理和虚拟 COM 端口。这些端口在设备管理器(Device Manager)中对用户不可见,但 Windows 仍会枚举它们,于是当你要创建一个其实已隐形存在的虚拟 COM 端口时就会失败。在多数情况下,下面这个过程可以让用户取消隐藏隐藏的 COM 端口,从而删除它们、消除可能的 COM 端口冲突。开始之前,请关闭电台,并关闭任何可能正在使用这些虚拟 COM 端口的程序,例如 SmartSDR CAT 或其他第三方应用。
- 单击 开始(Start),指向 所有程序(All Programs),指向 附件(Accessories),然后单击 命令提示符(Command Prompt)。
- 在命令提示符下键入以下命令,然后按 ENTER:set devmgr_show_nonpresent_devices=1
- 在命令提示符下键入以下命令,然后按 ENTER:start devmgmt.msc
- 在设备管理器中排查设备和驱动。
- 在设备管理器的 查看(View)菜单上单击 显示隐藏的设备(Show hidden devices),然后才能看到与计算机关联的所有设备。
- 向下滚动到 端口(Ports)一节,就能看到所有隐藏和未使用的 COM 端口。隐藏的 COM 端口旁边有一个灰显的图标。
- 要删除某个端口,单击它以将其高亮,然后按键盘上的 Delete 键。在 确认设备删除(Confirm Device Removal)对话框中,单击 OK。
- 删除未使用的隐藏 COM 端口后,列表中将只显示你正在使用或将来可能使用的 COM 端口。注意不要删除工作正常的 COM 端口。
- 排查完成后,关闭设备管理器。
- 在命令提示符下键入 exit。
请注意,关闭命令提示符窗口后,Windows 会清除你在第 2 步中设置的 devmgr_show_nonpresent_devices=1 变量,从而阻止在你单击“显示隐藏的设备”时显示已变为幽灵的设备。
最后——如果所有办法都无效——这里有 Peter DF1LX 的建议:“我遇到过这个问题,持续了几个月。这个帖子里提到的办法都没能帮我解决。只有用注册表编辑器搜索 comx 值才发现,另一个从不使用任何 COM 端口的程序却有一条指向该 COM 端口的注册表项。删除这条注册表项后问题就解决了。如果上述提示都不管用,我会把这作为最后的手段。”
电台接口
电台厂商提供了多种把电台与计算机连接起来以实现电台控制功能的方式。这些接口在计算机软件看来都像标准的 RS-232 串口,但实际使用的硬件差别很大。电台控制接口至少支持读取和设置工作频率与模式。大多数(但并非全部)支持计算机电台控制的电台还提供命令,让计算机控制 TX/RX 切换(PTT)。较新的电台还支持控制许多其他功能,例如 RIT/XIT 控制、滤波器切换和其他功能。
最早的电台控制接口一般使用电台连接器上的 TTL 电平,与 RS-232 信号电平不兼容,因此需要外部的电台控制接口盒,在 TTL(0 和 +5V)与 RS-232(-12V 和 +12V)逻辑电平之间进行电平转换。这些接口使用 RS-232 的 TxD 和 RxD 信号线进行数据通信,其中一些还需要 RTS/CTS 握手,而握手通常可以通过把 RTS 线始终置为有效来模拟。这些外部电台控制接口需要直流电源,可以单独供给,某些情况下也可以取自某条 RS-232 控制线(通常是 DTR 或 RTS),此时供电的那条控制线必须配置为始终有效。在计算机一端或硬件连接处,如果计算机没有串口,通常可以用 USB 转串口适配器代替。
一些较新的电台具有真正的 RS-232 串口,这样就无需外部电平转换接口,但除此之外它们的配置与早期的 TTL 电平电台控制端口类似。这些串口大多仍然只在 RxD 和 TxD 线上支持电台控制数据,可能辅以 RTS/CTS 握手;但至少有一种情况(Elecraft K3),电台的 RS-232 端口还支持用 DTR 和 RTS 控制线直接键控 CW 和 PTT 输入。同样,在连接的计算机一端可以使用真正的串口或 USB 转串口适配器。
近来,随着计算机上的串口越来越少见,一些较新的电台内置了 USB 转串口适配器,因此与电台的硬件连接就是一根简单的 USB 电缆。不过,这些 USB 端口的驱动在软件看来仍然是标准的 RS-232 串口。许多情况下,同一个 USB 连接还用来驱动电台内部的 CODEC(“声卡”),从而省去了计算机与电台之间的音频连接;但从软件的角度看,这一个 USB 连接表现为两个独立的设备:一个 RS-232 串口和一个标准计算机声卡。这两个设备必须分别配置,尽管它们共用一根电缆。
PTT 与 CW 键控的接口
选择 PTT 方式
PTT 是 RX/TX 切换的常用缩写(源自语音模式中的“push-to-talk”)。N1MM Logger+ 提供多种控制电台 PTT 的方式。除非你使用 VOX,或在 CW 上使用 QSK,否则你需要选择其中一种方式;具体选择可能取决于你想操作的模式、电台的能力以及你如何使用这些能力、已有的接口或为其他程序所做的其他 PTT 接线等。
一般而言,一次只应确定一种 PTT 方式。你可以在不同模式下使用不同的 PTT 方式,但在每种模式下都只应有一种方式处于活动状态。已知同时启用两种 PTT 方式会在某些电台上引发问题,例如发射结束后无法返回 RX。
可用的方式有:
- 硬件 PTT——使用串口(COM)或并口(LPT)。程序控制端口上各条线的状态来实现 PTT 和 CW(对于 LPT 端口,还可以从同一端口控制其他功能)。许多较新的电台提供了通过 USB 驱动为电台创建的虚拟串口上的控制线进行 PTT 键控的选项。在这类电台上,使用电台菜单选择用于 PTT(或“SEND”)键控的端口和控制线。这种方式在可用时很方便,因为不需要外部硬件。使用并口(LPT)键控时,可能需要一个特殊驱动(INPOUT32),它在程序初始安装时下载,但需要额外一步来注册——具体做法见安装软件。硬件 PTT 可用于 USB 转串口适配器,但不能用于 USB 转 LPT 适配器,Piexx SO2RXLAT 除外。在某些有多个 PTT 输入连接的电台上,选用哪个连接可能取决于你用于音频的输入端口的选择。
- 软件 PTT——使用通过电台控制端口发送给电台的软件 PTT(TX/RX)命令。这大概是最容易配置的方式,但在某些情况下可能不可用或不建议使用。在某些电台上,软件 PTT 可能不可用,也可能只在选择某些音频输入连接时才有效。另一方面,对于内置电台 CODEC(实际上是电台内部的声卡)的某些电台,如果你想把这个 CODEC 用于 AFSK(数字模式)或用作 SSB 的语音键控器,就可能需要使用软件 PTT。请查看支持的电台一节了解你的电台的设置说明。软件 PTT 在一些电台上表现良好,但在另一些 CAT 命令之间需要较长延迟的电台上,它可能比硬件 PTT 或 Winkeyer PTT 慢。对于 Icom 电台,如果 CI-V 总线上发生数据冲突,PTT 可能无法动作或一直停留在发射状态,需要用 ESC 返回接收。另请注意,N1MM Logger+ 无法控制电台内置 DVK 的 PTT(这里指的不是用于发送计算机中存储消息的 CODEC),因为如果录制的消息不是从计算机发出的,程序就无法知道该消息何时播完。因此这类 DVK 必须使用 VOX。同样,N1MM Logger+ 无法为从连接到电台内部键控器的双桨键发出的 CW 控制 PTT,因为它不知道双桨键何时被使用。
- Winkeyer PTT——使用 Winkeyer CW 键控器提供的 PTT,但也适用于 SSB 和数字模式。如果某个端口被设置为控制 Winkeyer,PTT 会在 Winkeyer 的真实面板插孔上自动激活,只需用电缆把它接到电台相应的插孔即可。如果你使用的是最初的 K1EL Winkeyer 版本 10,配置器(Configurer)的 Winkey 选项卡中的 Pin 5 Function 必须设置为 PTT(较新版本的 Winkeyer 不需要这样做)。Winkeyer PTT 是最灵活的 PTT 选项,尤其是在 CW 上,因为你可以把字符间“Hang Time”与消息末尾“Tail Time”分开设置。这些设置位于配置器中的 Winkeyer 选项卡。如果你选择使用其他方式控制 PTT,就不必接这根电缆。
- 数字模式 PTT——要在数字模式下把电台 CODEC 用于 AFSK,某些电台的 PTT 可能需要由 N1MM Logger+ 使用软件 PTT 来处理(见上文)。对于不使用内置电台 CODEC 的 AFSK,或者没有这一限制的电台,你可以使用 Logger 的其他任何 PTT 选项。如果你使用 FSK,通常会把软件和硬件配置为在 FSK 键控所用的同一端口上使用 PTT。如果你使用 MMTTY 之类的软件进行 FSK,FSK 端口上的 PTT 由数字软件“引擎”控制,而不是由 N1MM+ 本身控制。如果你只在数字模式下使用 PTT,可以只在数字程序中配置 PTT(例如 MMTTY)。但是,如果你在数字程序中配置了用于 PTT 和/或 FSK 键控的端口,而又想在非数字模式下把同一个 COM 端口用于 PTT,或用于 CW 键控,那么你必须在配置器 Hardware 选项卡中勾选该端口的“Digi”复选框。这会告诉 Logger:当你切换到数字模式时,关闭该端口并把它交给数字程序。如果你完全在 N1MM+ 中配置 PTT,而不在数字程序中配置,则不要勾选“Digi”复选框。
对于 SSB 或数字模式,可使用上述任何选项。请记住,如果你使用电台的音频 CODEC,可能需要使用软件 PTT,而不是 COM 或 LPT 硬件 PTT 控制。
对于 CW,如果你有 Winkeyer,且不使用 QSK 或半插入收发,而是想要 PTT 控制,那么推荐使用 Winkeyer PTT,因为它在设置 hang 和 tail 时间上最灵活。如果你没有 Winkeyer,但有串口或 USB 端口,可以用一个简单的晶体管开关接到串口或 USB 转串口适配器相应的线上来实现硬件 PTT。CW 和 PTT 可以在一个端口上处理。对于某些电台,如果电台不需要以特定方式使用 RTS 和 DTR 线来进行电台控制(例如在 RTS/CTS 上握手,这会使 RTS 线无法用于 CW 或 PTT 键控),也可能在同一端口上进行电台控制。
选择 CW 方式
N1MM Logger+ 提供多种在电台上键控 CW 的方式。
可用的方式有:
- 硬件 CW——使用串口(COM)或并口(LPT)(通常与电台控制端口分开)。软件控制端口上各条线的状态来实现 PTT 和 CW(对于 LPT 端口还有其他功能)。使用并口(LPT)时,可能需要一个驱动(INPOUT32),它由完整安装程序安装,但可能需要一次性“以管理员身份运行”的步骤来注册该驱动。这种方式可用于 USB 转串口适配器,但不能用于 USB 转 LPT 适配器,Piexx SO2RXLAT 除外。与 PTT 一样,许多带 USB 端口的新电台能够选择由 USB 驱动为电台创建的(某个)虚拟串口上的控制线(DTR 或 RTS)。这种选择很方便,因为不需要额外硬件。
- Winkeyer CW——使用 K1EL Winkeyer 或同类设备。这是最受推荐的方式,因为它几乎不受计算机中意外事件(例如 Windows Update、杀毒软件更新,或后台可能正在进行的其他资源密集型活动)引起的时序问题影响。使用 Winkeyer 时,CW 时序在计算机外部进行控制。Winkeyer 还可以配合双桨键当作普通 CW 键控器使用,其优点(相对独立键控器或某些电台内置键控器)是双桨键与计算机键控融为一体,例如触碰双桨键会中断计算机键控,而不会出现重叠或乱码,并且双桨键与计算机的速度一致。
使用 CAT 命令进行 CW 键控
不支持用 CAT 命令进行 CW 键控 有少数电台(Kenwood、Elecraft、Flex)允许通过“KY”电台命令消息发送 CW。一些带有内置 CW 存储器的电台可能允许用 CAT 命令发送这些存储器中的内容。Logger 团队不支持这些 CAT 命令方式。这并不意味着它完全不能用。你可以用 {CAT1ASC} 宏把这类电台命令消息编入功能键消息,但除了只适用于某些电台之外,这种方式还有若干其他限制:
- 每条功能键消息中只能放一个这样的 CAT1ASC 宏命令。
- KY 命令消息中可发送的字符数是有限的(某些电台还固定为某个确切字符数)。注意这是消息转换成的摩尔斯电码字符数(含空格),而不是 N1MM Logger+ 命令中字符的个数。因此你需要设计消息,使其不超过(或恰好等于)该字符数,即便使用你在比赛中可能遇到的最长呼号和交换内容也是如此。如果在编好的消息中超出长度限制,可能什么都发不出去。
- 无法用这种方式从程序中即兴发送摩尔斯电码,也就是说,用于发送键盘 CW 的 Ctrl+K 命令在这种方式下不起作用。
- 用这种方式无法在发送过程中即时编辑呼号。
- “发送更正后的呼号”功能在这种方式下不起作用。
- “CW 自动发送”功能在这种方式下不起作用。
- 用这种方式时,CW 速度由电台的 CW Speed 控制,而不是由 N1MM Logger+ 控制。Logger 的 CW 速度控制宏和 PgUp/PgDn 键在这种方式下都不起作用。
- 按下包含这类消息的功能键后,只有当电台支持通过 CAT 命令实现这一能力、且 N1MM+ 已为该电台实现时,你才能从 N1MM Logger+ 用 Esc 键中断消息。如果不支持,你也许能在电台上通过前面板控制中断正在发送的消息。
- 如果你想在 N1MM Logger+ 中使用自动 CQ 重复,重复间隔是从一条消息开始到下一条消息开始来计量的,也就是说,它既包括消息本身,也包括消息之间的时间。因此它必须长于你在最慢 CW 速度下 CQ 消息的持续时间。如果你用电台的速度控制改变 CW 速度,那么按最慢 CW 速度设置的重复间隔在较高速度下很可能比你想要的更长。
N1MM Logger+ 不支持用音频音调进行 CW 键控 团队有时会收到询问:为什么 Logger 的 CW 不能与向收发信机馈送音频音调的软件或接口单元配合工作。通常涉及 SignaLink USB 接口或 FLDIGI 软件程序。
N1MM Logger+ 不支持、将来也不会支持这种产生 CW 的方式。原因有几点。第一,在许多收发信机上,当它们处于 USB 或 LSB 模式时,你无法使用 CW 滤波器和其他 CW 接收辅助手段。第二,声卡 CW 问题很多,包括 CW 中的音频噪声、对 CW 音调的射频干扰,以及因音频谐波而产生两三个独立 CW 信号的可能性。这实在是个坏主意!
下面介绍的简单接口可以用容易获得的元件、以极低的成本轻松制作。
CW 与 PTT 键控电路
用于 CW 和 PTT 的并口(LPT)
这是一个典型的简单接口,可用于并口 CW 和 PTT 键控。CW 和 PTT 使用各自的电路(晶体管)。

| LPT 引脚 | 功能 |
|---|---|
| 1 | 选通 |
| 16 | PTT 输出 |
| 17 | CW 输出 |
| 18 | 地 |
关于诊断并口问题的提示,请参见稍后“并口的其他接口应用”一节下的说明。
串口(COM)
当串口用于 CW 和/或 PTT 键控时,使用的是 RTS 和 DTR 线。
| DB9 引脚 | DB25 引脚 | 功能 |
|---|---|---|
| 7 | 4 | PTT 输出(RTS) |
| 4 | 20 | CW 输出(DTR) |
| 5 | 7 | 地 |
CW 与 PTT 端口分配 一台电台的 CW 和 PTT 线必须在同一个串口/并口上。例如:当 COM4 是 CW 端口且选择了 Radio 1 或 Both 时,Radio 1 的 PTT 控制也必须在 COM4 上。支持 USB 转串口转换器,但不支持 USB 转 LPT(并口)转换器。
使用晶体管
串口 CW 或 PTT 键控的键控电路与并口所用的电路类似。

**
- 2N2222 的等效型号有 2N3904、BC547 或 BC548。
- 注:在基极与地之间加一个 1 kOhm 电阻并不是坏主意;还强烈建议在集电极输出对地加一个 10 nF 的旁路电容,以防止射频反馈到基极并造成后续阻塞。
使用光隔离器(光电耦合器)
有些用户更喜欢用光隔离器而不是晶体管,以便在下游出问题时为串口提供更多保护。但在这种情况下,可能需要注意两点:
-
你可能需要在光隔离器的输入端串联一个二极管,以保护它不受标准串口上负电压摆幅的影响。请查看所用光隔离器的规格,确定是否需要这样做。
-
有些光隔离器的输出可能无法拉得足够“低”(足够接近零伏),从而无法在特定收发信机上切换 PTT 或 CW。在这种情况下,必须采取适当的“下拉”措施。
USB 端口键控
现在不是所有计算机都有串口,即使有,数量也不够用来控制收发信机、分组无线电、串口 CW 键控等。这种情况下可以考虑 USB 转串口适配器。它们大多能很好地完成基本的电台控制功能和/或 CW 与 PTT 键控。这些设备需要计算机内的驱动;在尝试使用这类适配器之前,请确认有适用于你的操作系统的驱动。
串口或并口键控的时序可能会因 CPU 忙于其他任务而无法控制端口,出现“卡顿”。要想获得不依赖 Windows 进程的完美 CW,通常的答案是使用 K1EL 的 Winkeyer。计算机通过串口以普通 ASCII 字符与 Winkeyer 通信,这些字符在 Winkeyer 内部缓冲并转换为 CW。因此 CW 时序与计算机处理延迟无关。USB/串口适配器可以与 Winkeyer 良好配合;事实上,现在交付的大多数 Winkeyer 都是内置 USB 转串口适配器的 WKUSB 键控器。更多信息请查阅 Winkeyer 手册。
在某些情况下,使用 USB 转串口转换器时 PTT 和 CW 键控可能意外停止工作,因为 Windows 已关闭 USB 端口以节省电源。请检查以下 Windows 设置:
- 控制面板(Control Panel);系统图标(System Icon),
- 硬件(Hardware)设备管理器(Device Manager)选项卡或按钮。
- 展开 USB Serial Bus Controllers
- 依次高亮每个 USB Root Hub 或 Generic USB Hub
- 双击打开属性设置,进入电源管理(Power Management)选项卡
- 取消勾选“允许计算机关闭此设备以节约电源”
- 在大多数情况下该复选框默认是勾选的
- 对每个 USB Root Hub 和 Generic USB Hub 重复上述操作
- 重新启动计算机
关于串口转 USB 转换器的另一篇综述可见 AA5AU 的 RTTY 比赛页面,地址:http://www.rttycontesting.com.
并口的其他接口应用
如果所选 CW 端口类型是 LPT1、LPT2 或 LPT3,并且使用硬件 LPT 端口,那么所选并口上还会有其他信息。在配置器中,选择与所选端口对应的电台(Radio 1 或 Radio 2)。LPT 上的 BCD 数据是当前活动电台/VFO 的数据。频段数据可在多个 LPT 端口上获得——Radio 1 在 LPT1 上,Radio 2 在 LPT2 上,以此类推。不支持 USB 转 LPT 转换器。
LPT 引脚与说明 1 PTT 和 CW 输出的回路。此引脚的吸收能力有限,可能需要缓冲 2 由配置器中天线(Antenna)选项卡设置的频段输出(最低有效位)。此引脚还用于停止通过硬件 DVK 发送的消息。 3 兼容 NA 的 TX 焦点。– Radio 1/2:当 Radio 1 具有 TX 焦点时,引脚 3 变为逻辑低电平(0V);当 Radio 2 具有 TX 焦点时,变为逻辑高电平(5V)。(注:LPT 引脚 3 是引脚 14 的互补。)仅当未选择硬件 DVK 输出时才设置(msg# 1)。 4 兼容 NA 的 RX 焦点。当 Radio 1 具有 RX 焦点时,LPT 引脚 4 变为逻辑低电平;当 Radio 2 具有 RX 焦点时,变为逻辑高电平。仅当未选择硬件 DVK 输出时才设置(msg# 2)。 5(Shift+singlequote)用于在立体声与单声道之间切换。单声道音频时 LPT 引脚 5 为逻辑低电平,立体声音频时为逻辑高电平。仅当未选择硬件 DVK 输出时才设置(msg# 3)。 6 仅当未选择硬件 DVK 输出时才设置(msg# 4)。 7 由配置器中天线选项卡设置的频段输出 8 由配置器中天线选项卡设置的频段输出 9 由配置器中天线选项卡设置的频段输出(最高有效位) 14 电台选择 A/B(发射焦点),用于兼容 DX Doubler。当 Radio 1 具有 TX 焦点时,LPT 引脚 14 变为高电平;当 Radio 2 具有 TX 焦点时,变为低电平。(注:LPT 引脚 14 是引脚 3 的互补。) 15 脚踏开关输入端口 16 PTT 输出,高电平 = 发射模式 17 CW 输出 18 – 25 频段输出的回路
并口问题诊断
所有 PCI-e 并口卡都能用吗? 技术发展如此之快,很难对此下绝对结论;反射器上也有一些讨论,暗示某些系列的 LPT 端口芯片与 N1MM Logger+ 用来控制 LPT 端口各条线的软件组件不兼容。不过,实验结果表明,截至 2013 年二月,有两个系列的芯片确实可用:这些芯片既用于单端口卡,也用于组合卡(例如两个串口加一个并口),但只在单 LPT 端口这种变体上经过系统性测试。
- MOSChip Semiconductors 的 MCS9900 系列。该公司现属 Asix Electronics Corporation。最新驱动可在此处下载。产品系列请指定 PCIe Bridge。这些芯片用于 SYBA SD-PEX10005 单端口并口卡,可从常见的在线渠道购买。
- Oxford Semiconductor 的 OX16PC952-954。该公司的芯片用于多种单端口 LPT 卡,包括同样广泛销售的 StarTech.com PEX1P。最初认为它们与并口切换不兼容,但看来并非如此(详情请联系 N4ZR)。
诊断 LPT 端口问题 最近,不少用户在使用 PCI-e LPT 端口控制频段解码器、SO2R 控制器和其他设备时遇到困难。经过大量实验,如果你遇到问题,可以尝试以下几点。
- 确保在 N1MM 的配置器中指定了正确的地址。通常,PCI-e 扩展卡似乎具有并非该端口号标准地址的 I/O 地址。例如,内置 LPT1 端口在我们这里通常地址为 0378,它是设备管理器中为该端口给出的两个 I/O 地址中较低的那个。另一方面,测试过的 3 块不同 PCI-e 卡无论 LPT 端口号如何,I/O 地址都固定为 D000 和 D010,而正确的地址是较高的那个——D010。拿不准时,两个都试试。
- 新安装后第一次运行 N1MM Logger+ 时,不要从快捷方式运行。而应进入 N1MM Logger+ 程序目录,右键单击可执行文件(.exe),然后选择“以管理员身份运行”。有人建议,某些情况下为了让驱动并口的组件正确注册,这一步可能是必要的;做了也无妨。这只需做一次。
外部 DVK 接口
当你在并口上选择 DVK 时,通过该端口进行的天线选择会被禁用,因为 LPT 端口上的 DVK 引脚与天线引脚重叠。以下是外部 DVK 控制的引脚引出表: F1 引脚 3 F2 引脚 4 F3 引脚 5 F4 引脚 6 F5 引脚 4 和 6 F6 引脚 4 和 5 F7 引脚 4、5 和 6。
按下 F1-F7 时,会向相关引脚发送一个 100 ms 的脉冲,用于控制外部 DVK。
要在外部 DVK 上录制消息,你需要把话筒直接接到它上面,并按 DVK 手册中所述的步骤操作;N1MM Logger+ 的支持仅限于在按下相应功能键(F1-7)时触发前 7 个存储器,以及在按下 ESC 键时停止已存储消息的播放。有些外部 DVK 只有 4 个存储器,这种情况下只有 F1-F4 会触发播放。
频段解码器输出
引脚 9、8、7 和 2 可以用配置器中的天线选项卡进行设置。引脚上的输出将遵循所选天线所设置的代码。

示例配置

要复现 Top-Ten Devices 的默认行为,你需要按上图左侧所示设置配置器中的天线选项卡| N1MM Logger+ 可以为每个频段使用一副以上的天线。用 Alt+F9 可以在这些天线之间切换。把每副天线的频段列出来,用逗号分隔——例如 3.5,7
示例配置 > 两副堆叠天线的天线设置

你需要在频段解码器的输出端用二极管矩阵做适当的安排,以便当程序向解码器发送某个代码时选中相应的天线。例如,如果你的频段解码器输出正电压,而你使用一副三频段定向天线、单根同轴馈线,就需要用二极管把频段解码器输出的三路信号合并到这一根馈线上。
方位数据
用于旋转器控制的方位数据目前无法从 LPT 端口获得。
声卡接口
当然,你总可以使用众多主要为数字模式设计的商用音频接口。不过,如果你的声卡允许把话筒输入馈送到线路输出(大多数都可以),并且有一个混音器可以分别设置话筒、.wav 播放和内部生成音频(例如 AFSK)的电平,那你根本不需要接口。在 SSB 上,只需把话筒插到声卡的话筒输入。把声卡的 Line Out 接到收发信机的 Line In 或 Phone Patch 输入,就完成了。
你可能会遇到交流声,它源于计算机机箱与收发信机机箱之间的交流电位差。这种情况下,在声卡与收发信机之间的电缆中加一个 600 欧姆的隔离变压器即可解决。另一种办法是用粗导线把收发信机与计算机机箱连接在一起。许多人两种办法都用。
如果你一定要把声卡的音频输出接到收发信机的话筒插孔,电平会太高。这种情况下,解决办法是在音频电缆中、话筒插孔之前加一个简单的 10:1 电阻分压器。
在 Windows 10 和 11 中,从 2018 年某个时候起,Windows 有一项隐私(Privacy)设置必须正确设置,应用程序(包括 N1MM Logger+)才能访问声卡输入(例如录制接收音频或解码数字模式)。在 Windows 设置(Settings)窗口中,选择“隐私”,然后在窗口左侧的区域中选择“麦克风(Microphone)”。应会出现一个名为“允许应用使用我的麦克风”的选项。把它设为“开”。从 Windows 10 的 2018 年春季版本开始,Windows 把此设置解释为适用于所有声卡输入,而不仅仅是默认话筒输入。
Windows XP/ Vista/ 7/ 8/ 10/ 11 下的串口与并口接口
Windows XP、Vista、7、8、10 和 11 需要一个特殊的 dll,N1MM Logger+ 会自动安装它以使用并口。
显示并删除幽灵串口
与 N1MM Logger Classic 不同,N1MM Logger+ 支持编号最高到 99 的串口。下面的过程多半并不必要,但你仍可能想用它来清除系统中的“幽灵”(未使用但不可用的)串口,
下面是让设备管理器显示并移除不可见串口分配的方法:
- 单击 开始(Start)按钮,选择 所有程序(All Programs)> 附件(Accessories)。
- 在 Windows XP 中,单击 命令提示符(Command Prompt);在 Windows Vista、7 或更新版本中,右键单击 命令提示符(Command Prompt),然后选择 以管理员身份运行(Run as administrator) 菜单项。
- 键入 set devmgr_show_nonpresent_devices=1,然后按 Enter 键。
- 启动设备管理器。方法有很多;其中一种是右键单击 计算机(Computer)(或我的电脑),选择 属性(Properties),然后单击 设备管理器(Device Manager)。另一种是在控制面板中找到 设备管理器(Device Manager)。
- 在设备管理器窗口中,选择 查看(View)> 显示隐藏的设备(Show Hidden Devices) 菜单项。
- 单击“端口”旁边的 + 号,查看计算机中已分配的全部 COM 端口列表。
- 高亮你想从列表中移除的未使用端口号,然后按 Delete 键。在要求确认时接受,然后继续删除你想删除的其他端口号。
感谢 KK1L 和 N7WY 提供此技巧。
连接脚踏开关
脚踏开关可以接到串口或并口。脚踏开关的程序动作对 LPT 和 COM 端口是相同的,即脚踏开关闭合会触发配置器中为该端口选定的动作。
并口
如果引脚 14 未被用于通过外部 SO2R 盒切换电台(例如使用 Pause 键),那么把脚踏开关接到 LPT1 的方法是:在引脚 14 与引脚 15 之间接一个 10k 电阻。引脚 14 通常为 +5V,为引脚 15 提供上拉电压。然后在 LPT1 的引脚 15 与引脚 18 之间接一个常开脚踏开关。闭合脚踏开关会把引脚 15 拉低,并执行配置器中选择的功能。
如果引脚 14 已用于外部 SO2R 盒的电台 A/电台 B 控制,可以用一个 5V 电源串接 10k 电阻来为引脚 15 提供上拉电压。
串口脚踏开关信息(使用 9 针连接器编号)
在引脚 6 与引脚 7 之间接一个 10k 电阻。把 DTR(引脚 4)设为“始终开启”,把 RTS(引脚 7)设为“始终关闭”。把脚踏开关接在引脚 4 与引脚 6 之间。 脚踏开关闭合时程序将执行动作。脚踏开关的导线不能参考地电位,也不能接地。
避免 RFI 与其他常见接口故障
关于电台控制、CW 和 PTT 接口出现古怪、间歇性问题的报告,以及声卡音频中的交流声和失真,多半最终都追溯到 RFI——你自己的信号出现在了不该出现的地方,或者接地不当。
虽然我们没有足够的篇幅详尽讨论这个话题,但有几个不错的资源——RFI 反射器(RFI@contesting.com)、Chuck Counselman(W1HIS)的这篇论文,以及 Jim Brown(K9YC)的这些论文
USB 接口设备
随着大多数新 PC 上串口和并口的消失,现在大多数 N1MM Logger+ 用户不得不使用 USB 接口设备来完成以前用串口和并口完成的功能。这些设备包括消费级 USB 转串口适配器,也包括专为业余无线电设计制造的设备。大多数情况下,借助设备首次连接到 PC 时安装的软件驱动,这些设备在 N1MM Logger+ 中的配置方式就像真正的串口一样,但也有一些重要的注意事项和例外,将在以下几节说明。
另一类 USB 设备是“USB 声卡”,其功能与板载和总线式声卡类似,只是它通过 USB 端口与 PC 接口。一些面向业余群体的设备把 USB 声卡和 USB 转串口适配器合并在一个盒子里。现在有些收发信机出厂时就内置了这类 USB 设备。一般来说,安装好相应驱动后,无论是在收发信机内部还是在一个或多个独立盒子中,这些设备的配置方式都相似。
USB 转并口适配器一般不能用
USB 转并口适配器无法通过标准并口接口键控 CW 或控制 PTT,因为这些适配器不允许控制单条线。 我们所知的唯一例外是 Piexx 的 SO2RXLAT,它正是为此目的而设计的。
USB 适配器的 CW 问题
N1MM Logger+ 的串口与并口 CW 选项是生成 CW 的简单便捷方式,但如果你的计算机较慢,你可能会发现 CW 并不总是平滑,尤其是在繁忙的比赛中从 Telnet 集群接收台情时。如果串口键控出现这种情况,手头有并口的话可以改用并口。如果没有并口,或者你想一劳永逸地解决 CW 问题,答案就是 K1EL 的 Winkeyer USB,它把 CW 和全模式 PTT 功能完全从计算机卸载下来。它同时也是一台出色的独立电子键控器,内置 4 条存储消息。
另一个问题可能是使用串口键控时点划比例(weighting)不佳。有些适配器延迟很大,会把你的 CW 弄得一团糟。通常可以通过为该适配器寻找更好的驱动来纠正。请确保你运行的是操作系统的最新厂商提供驱动,而不是操作系统自行选用的那一个。有些适配器允许你在控制面板中设置延迟。
关于 USB 转串口 I/O 接口设备的总体说明
N1MM Logger+ 用户在使用 USB 转串口适配器时,经常会遇到三类不同的问题。
第一个是 Windows 关闭一个或多个 USB 端口导致通信中断。该问题及其解决办法见这一节。
第二个问题与这些适配器所用的具体芯片组和驱动有关。这类适配器的市场由两种芯片组主导,分别叫作 Prolific 和 FTDI。使用 Prolific 芯片组的适配器在 N1MM Logger+ 中进行串口通信(特别是电台控制)时可能存在潜在问题。此问题只影响真正的串口通信;用于 CW 和 PTT 键控的 DTR 与 RTS 简单通断键控不受影响。Prolific 芯片组有多个版本(包括假冒仿制品),驱动也有多个版本,其中至少有一些驱动与 N1MM Logger、DXLab Suite、Logger32 以及其他一些业余无线电程序所使用的 Microsoft 库例程不兼容。症状是出现带错误号 8020 的错误消息。结果是:在某些 Prolific 芯片组和/或驱动软件的组合下,使用 Prolific 芯片组的适配器可能无法在 N1MM Logger+ 中正常进行电台控制及类似用途。与其罗列芯片组版本、驱动版本与操作系统的所有可能组合来判断哪些可用、哪些不可用,我们最简单的建议是:不要把使用 Prolific 芯片组的 USB 转串口适配器用于电台控制、旋转器控制或类似的串口通信用途。
第三个问题涉及从 MMTTY 进行 FSK RTTY 键控。MMTTY 可以使用真正的串口进行 FSK 键控,办法是把该端口编程为以 45.45 波特发送 5 位字符。遗憾的是,大多数单端口 USB 转串口适配器——至少那些新到能与 Windows 7 配合使用的适配器——无法慢到足以发送 45.45 波特的 Baudot。有些多端口适配器(从一个 USB 端口分出两个或四个串口,例如 Edgeport)能够慢到足够程度,但目前仍在销售的单端口适配器中,若真有能做直接 FSK 键控的,也是凤毛麟角。
标准的解决办法是使用 EXTFSK(或在 CPU 支持的系统上使用 EXTFSK64)。EXTFSK 在内部完成全部定时,而不使用串口硬件。EXTFSK 能够在任何串口或任何 USB 转串口适配器的 TxD、RTS 或 DTR 线中的任意一条上键控 FSK,甚至可以在真正的并口上键控(但*不*能在 USB 转并口打印机适配器上使用,这类适配器没有位操作能力)。使用 EXTFSK 有一个缺点——其定时精度不如来自真正串口的硬件定时。这可能导致在困难条件下信号的可读性略差。
据我们所知,没有哪种 USB 转串口适配器在 EXTFSK 或 EXTFSK64 的帮助下仍无法进行 FSK,也没有哪种 USB 转串口适配器无法在其 DTR/RTS 线上键控 CW 或 PTT——除非该适配器根本没有为这些控制线提供物理连接(例如 Elecraft KXUSB 未实现 DTR 和 RTS 控制线,因此无法使用 DTR 或 RTS)。
驱动:有一件事绝对不能做,那就是听信 Windows 说自己已经有某个特定设备的驱动——你应当始终安装随你的接口附带提供的驱动。Windows 可能在你插入这些设备时把它们认错,并且会用它自认为正确的驱动让你失败——而 Windows 往往是彻底错的。
一般来说,在 XP 下,只要没有冲突,你几乎可以使用任何 USB 转串口设备(Prolific 或 FTDI 芯片组)。到了 Vista 或 Windows 7 及更新版本,要想结果基本可靠,FTDI 似乎成了唯一的选择(编者注——并非所有用户都同意这一说法。)
即便有以上种种,取决于你此前对计算机做过什么,你仍可能遇到问题。再次强调,所有这些的要点在于:问题可能与你试图使用的硬件毫无关系,而可能是计算机上早先某项活动遗留下来的东西。话虽如此,这些设备的大多数安装在开始时就一切顺利。一旦不顺利,就可能非常令人沮丧。
Joe(W4TV)发布在 N1MM Logger 邮件列表上的一条技术补注,介绍了一种判断某个适配器能否处理 45.5 波特 RTTY 的简便方法:
Windows 串口驱动用一个“双字”中的 14 位来设置数据速率(波特率除数)。这把驱动/UART 的最大/最小范围限制为 214:1 … 而任何高于 512K 的最大速率都将排除以 45.45 bps 工作的可能。
较低的速率并不能 100% 保证兼容,但较高的速率明确意味着 RTTY 将需要使用 EXTFSK 或 AFSK。
声卡接口与 USB 外置声卡
如果你想录下比赛中的 QSO,或在语音比赛中使用存储消息,就需要把计算机与收发信机的音频系统连接起来。
这需要事先稍作考虑。如果你既想录制 QSO,又想使用存储消息,那么就需要一个既有线路(Line)输入又有麦克风(Microphone)输入的音频设备(无论是内置还是外置),并且它要能进行双工工作——也就是说,它可以同时录音和放音。这并非罕见能力,也不是只有昂贵声卡才具备,但在选购声卡时值得核实。
如今更常见的问题似乎是声卡——尤其是集成在笔记本电脑中的声卡——只有一个输入,可用于线路输入或麦克风输入,但不能同时用于两者。遇到这种情况,最好的办法也许是买一块外置 USB 声卡。同样,这个用途不必追求高端,只要满足上面两条标准即可。
经 N1MM Logger 测试过的两块外置 USB 声卡是 Encore,由 NewEgg 在此销售,价格不到 US$20;以及 GWC,同样由 NewEgg 在此 URL 销售,价格大致相同。ByteRunner UA-580 也能正常工作。(感谢 Joe W4TV 提供此信息)
支持的硬件
Windows 与外置 USB 外设
关于外置(USB)声卡……以及其他 USB 外设,有一句提醒。
Windows 只能寻址“USB 根集线器”……它们直接连接到内部 PCI 总线。Windows 会并行处理一台机器中所有“根集线器”的数据。然而,所有“子”设备就像一棵树上的叶子,每一片从同一“根”上“长”出的叶子依次获得一个时间片(一般为 16 毫秒)。如果一个根集线器上的“叶子”太多,延迟就会变得过大,导致与作为控制方的软件(Logger)通信失败(超时)。
如果某些软件每 50 到 100 毫秒轮询一次,并且在下一次轮询间隔之前没有收到响应就超时,这个问题会尤其突出。USB 可以轻松承受总吞吐量(大约 240 mb/sec),但如果软件作者没有把这些延迟考虑进去,延迟就可能成为问题。
如果你使用外置集线器并接入许多设备——尤其是存储棒和“U 盘”这类设备——请特别注意此问题。
73, Joe Subich, W4TV
Green Heron Engineering Inc. – GH Everyware(旋转器控制)
N1MM Logger 可以把方位信息直接发送给 Green Heron GH Everyware 软件。N1MM Logger 必须配置为通过网络(使用 UDP 数据包)发送旋转器信息。这可以通过编辑 N1MM Logger.ini 文件来完成。相关信息见 Green Heron 软件随附的文档;该软件与 Everyware Remote 和 Base 硬件捆绑提供,不单独销售。
更多细节请参阅 Everyware 文档。
Ham Radio Solutions – EZmaster
EZ Master 是一个 LPT 端口与 USB 设备,把你的 PC 与电台室中的多种设备连接起来,如电台、天线、滤波器切换、麦克风、耳机等。其中包括 PHONE、CW、RTTY、DIGITAL 模式接口以及内置 DVK、CW 电子键控器和 SO2R 切换。
更多信息见 Ham Radio Solutions 网站。
K1EL – Winkeyer
Winkeyer 是由 K1EL 和 G3WGV 设计的外置键控器芯片,它把完整的电子键控器功能与到计算机的串口接口结合在一起。Winkeyer 旨在与兼容的 Windows 软件接口,并根据发送给它的 ASCII 字符产生 CW,从而避免多任务处理引起的 CW 定时问题。
N1MM Logger 是最早支持 Winkeyer 的 Windows 日志程序之一,如今它已成为 N1MM Logger+ 用户喜爱的 CW 解决方案。串口或并口键控或许也能正常工作,尤其是在较快的计算机上,但使用 Winkeyer 可以让你用较慢的机器凑合,或在运行 N1MM Logger+ 的同时运行其他程序,而依然保持 CW 完美。市面上有独立式电子键控器,Winkeyer 键控器芯片也被用于多功能接口,如 Ham Radio Solutions EZMaster、RigExpert 以及若干 microHAM 接口。
更多信息见 K1EL 网站。
关于如何设置 N1MM Logger+ 以配合 Winkeyer 使用的完整说明,见 N1MM Logger+ 手册的配置器一节。
microHAM – microKEYER
关于如何配置 N1MM Logger 以配合各种 microHAM 产品的权威信息来源是 microHAM 网站,该网站提供了各种“示例配置”。这些配置也可以从 microHAM Router 软件的帮助菜单中的“Document Download”下访问。
Tentec ORION + “支持的电台静音麦克风”(Mute mic on supported radios)
在配置器(Configurer)对话框的其他(Other)选项卡中,确保*未*勾选“支持的电台静音麦克风”。如果勾选了该项,Logger 会在 DVK 操作期间把麦克风静音并打开 AUX 输入。按设计,microKEYER 会把 DVK 音频送到麦克风输入端。
ICOM CI-V 接口 + Transceive 开/关功能
如何把 microHAM 设备与 N1MM Logger+ 连接起来,同时还要接上例如 SteppIR 天线——它需要把 Transceive 打开才能知道电台频率,而 N1MM Logger+ 又希望看到 Transceive 关闭。
- 把所有 CI-V 设备并联连接(芯线对芯线,地线对地线)
- 关闭 Icom 电台的 Transceive
- 在 microHAM Router 中打开“轮询”
- 在 microHAM Band Decoder 中关闭“轮询”
microKEYER(Router)只会在日志软件不轮询时进行轮询(例如,即使 N1MM Logger+ 不轮询,Router 也会轮询)。Router 的轮询会让数据持续在 CI-V 总线上流动,使 SteppIR 和其他类似硬件保持“同步”。
microHAM Band Decoder 会根据你的常规编程提供天线切换(包括在配用合适的外部开关时支持每个频段多副天线),为带通滤波器(若干品牌)提供驱动,还能进行“格式转换”,让 Yaesu(Quadra、FL-7000)或 Icom(IC-2KL、IC-4KL、IC-PW1)固态功放可以与任何其他(受支持的 Yaesu、Kenwood、Icom 或 TenTec)电台配合工作。
非 Icom 电台也具有同样的能力。
N1MM Logger+ 无法读取 RX 频率(显示为 0)——不用 Logger 时频率在 microHam router 中显示正常
N1MM Logger+ 轮询的数据与 Router 略有不同(VFO A 和 VFO B,而 Router 是“当前工作频率”),因此 Router“超时”。解决办法:
打开 Router | Control | Set,然后取消勾选“Disable router queries”。
消息被截断(使用 Winkeyer 键控器时)
症状:除最后一个字母外,所有宏 CW 消息都能发出,然后回到接收状态。解决办法是在宏消息末尾加一个空格或 | 字符(即上档的 \ 字符)。| 字符大约相当于一个空格的 1/3。
microHAM – MK2R/MK2R+
- 要使用 LPT 控制把 MK2R+ 与 N1MM 配合设置,见:http://www.microham.com/Downloads/MK2R\_N1MM\_Setup.pdf
问:当我加载 N1MM logger 时,消息显示:“Winkeyer v2 detected, Only Winkeyer v4 and higher are supported in N1MM.” 答:那是某种 Winkeyer 初始化错误,当启动 N1MM logger 时 MK2R+ 没有开机就会出现。
问:MK2R 要完全正常工作需要多少个串口 答:无论如何,要构成与 N1MM 配合的完整系统只需要五个端口(Radio 1、Radio 2、PTT 1、PTT2 和 Winkeyer)。任何其他功能(Packet、旋转器控制等)都不需要 处于“前八个”之列。MMTTY/Digital Interface 会与 PTT 共用一个端口(如果不使用 Winkeyer,也共用 CW)……而工作在 AFSK 模式下的 MMVARI 或 MMTTY 则完全不需要端口。即使 SO2R 控制信号被映射到串口握手线,或者软件增加了对 microHAM 控制协议的支持(在虚拟端口上),多出的一个端口也不会让大多数系统“越界”——不过,能够从 COM1 以外的位置开始这八个端口块,会多提供一点保障。
73, Joe, W4TV
一个示例设置
microHAM Router
- 两部电台的 VOICE 音频切换:CmCmCm
FT1000MP,Proset Plus 插在前置麦克风插孔上。
N1MM Logger(6.10.9 或更高版本)
- 配置器 >音频选项卡(Audio)
- 2 – 单卡 – 两部电台,无 SO2R 声卡(Single Card, Two Radio, No sound card SO2R)
- 选择设备(Select Device)= USB Voice CODEC
- 选择输入线路(Select Input Line)= Microphone
- 选择静音线路(Select Line to Mute)= Microhone
- 录制位数(Recording bits)= 16
- 采样率(Sampling rate)= 22050
Ctrl+Shift+Fx 用于录制,Fx 用于回放。
仅 USB 的 SO2R 支持
使用 MicroHam SO2R 协议的仅 USB SO2R 支持之后,就不再需要 LPT 端口来向 MK2R/MK2R+ 下达各种 SO2R 功能命令了。
在 N1MM logger 中指定一个虚拟 COM 端口作为你的 MK2R 控制端口。为此,勾选该端口的 CW/Other 复选框,单击“设置”(Set),并在端口详细信息对话框中勾选 MK2R 复选框。然后转到 MicroHam Router 上的 SO2R 选项卡,用“单选按钮”选择 Microham SO2R protocol,并在正下方的下拉列表中指定该 COM 端口。最后,如果你想使用程序导出的频段数据,请在 ACC 选项卡上把 Radio 1 和 Radio 2 选项改为“SO2R protocol controlled”。如果你想为两部电台控制频段解码器,可能需要接一根新电缆,从 ACC 连接器的 6-9 脚取 Radio 1 数据,从 10-13 脚取 Radio 2 数据。
程序内的即时录制在使用仅 USB 方式时受支持。
Joe(W4TV)建议的端口设置
“MK2R/MK2R+ 在总共六个端口下运行得非常好(我将用 A – F 来避免使用具体数字):
MK2R/MK2R+ 使用 6 个端口
| 端口(Port) | 连接的设备(Connected device) |
|---|---|
| COM A | Winkeyer(最好把 Winkeyer 分配给“最低”的端口,以免在为 CW 启用另一个端口时丢失 CW) |
| COM B | 电台 #1(本端口上的 PTT 和脚踏开关为可选) |
| COM C | 电台 #2(本端口上的 PTT 和脚踏开关为可选) |
| COM D | 数字 #1,用于电台 #1 的 FSK 和 PTT(分配 Radio 1) |
| COM E | 数字 #2,用于电台 #2 的 FSK 和 PTT(分配 Radio 2) |
| COM F | MK2R(协议端口) |
不选择使用 FSK 的用户(只用 AFSK)可以用四个虚拟端口应付,因为可以在每个电台端口上启用 PTT——即使电台通常要求“握手”也可以,因为 MK2R 会完成握手,并让 RTS/DTR 两条线都空出来用于控制功能。”
如果你想配合 PTT(而不是 VOX)使用 N1MM Logger 内置的“DVK”,那么 COM D 和 COM E 的 PTT 设置(或可选的电台端口 PTT)是必需的。这并不意味着你必须把端口选项卡上的 COM 5 和 COM 6 指定为 PTT——你只需确保在 Router 中勾选了两个 FSK 端口上的 PTT 复选框即可。如果你改用 MK2R 内置的 DVK,则需要在你用于 MK2R 的端口上勾选“DVK”复选框。
在 N1MM Logger 内即时录制
要让配合 N1MM 与 MK2R+ 的 Ctrl+Shift+Fx 即时录制正常工作,有几个不寻常的要求:
- 如果使用 MK2R SO2R 协议(仅 USB),你需要使用 MM 7.10.9 或更高版本
- 如果你的计算机板载声卡使用 Realtek 或 Soundmax 芯片,那么你需要临时把 USB Voice CODEC 设为 Windows 的默认音频设备,并确保在此期间关闭所有 Windows 声音(同样在控制面板中操作)。Realtek/Soundmax 驱动中存在一个缺陷,除非这样做,否则麦克风音频无法送到 MK2R+ 的 USB Voice CODEC(它用该编解码器录制和播放功能键消息)。
RigExpert
为 RigExpert Std 或 Plus 安装驱动时,它会在你的计算机上创建 4 个虚拟 COM 端口以及 USB Audio Codec(用于其内置声卡)。一些 RigExpert TI-5 接口的用户报告说,用于 FSK 键控的第 4 个虚拟端口无法与 MMTTY 配合。仍然可以使用第 2 个虚拟端口(PTT/CW/SoftFSK),配合 RigExpert 随附版本的 EXTFSK,并把 MMTTY 配置为使用 EXTFSK,来键控 FSK RTTY。 单击“显示串口”(Show Serial Ports)(RigExpert 软件随附的 ListRE 程序),记下 CAT 和 PTT/CW 的 COM 端口号,以备将来参考。 然后运行你的 N1MM。(确保不要同时运行其他日志程序,以避免端口冲突)。 转到 Configure,单击 Configure Ports, Telnet Address, Other。单击 Hardware。你会看到从 COM 1 到 COM 8 的 COM 端口选择。为 CAT 选择正确的 COM 端口号(就是你之前记下的那个),选择你的电台型号,并在 Details 中为你的电台选择正确的参数(波特率等)。然后为 CW/PTT 选择正确的 COM 端口号(勾选 CW/PTT),并在详细信息中把 DTR 设为 CW、把 RTS 设为 PTT。如果你使用的是 RigExpert Plus,还可以为 Winkeyer 单独设置一个 COM 端口。 如果你想把 RigExpert 用作声卡(用于 SSB 消息或 RTTY),可以转到 Audio(在同一个配置器菜单下),然后选择 USB Audio Codec 作为你的声音设备。 别忘了,你不能同时运行两个使用同一 USB 接口的程序。 如果你有较旧的 RigExpert——SD 或 2.2,仍然可以在 N1MM 中使用它,只需安装额外的驱动(REAUDIO)。
把 RigExpert SD 与 N1MM 配合用于语音键控时,在配置器的 Audio 中选择“RigExpert”作为设备。然后在“Files”中配置录制 wav 文件的路径。 较旧的 RigExpert 型号需要安装 REAUDIO。较新的 RigExpert 型号不需要 REAUDIO,“Select Device”菜单中应选择“USB Audio Codec”。
Top Ten Devices – Band Decoder 与 DX Doubler
要复现 Top Ten Devices 的默认行为,你需要按接口一节所示设置配置器 >Antenna 选项卡。
硬件更新:从键盘实现“双耳听非活动电台”与“双耳听活动(或主叫)电台”
我想更进一步,模仿 DXD 的“PTT”操作——它在激烈的搜索呼叫(S&P)时把双耳都放在非活动电台上,但我仍然希望能从键盘把双耳放到活动(或主叫)电台上,以便在 HC8N 于 S&P 电台上以 S9 +40 轰响时,帮我听清对我 CQ 的微弱应答。你可以通过把 DXD 音频模式开关从 PTT 拨到 Auto 来手动实现,但我更愿意让双手留在键盘上。
在与 Top Ten 的 George(W2VJN)和 Dave(N3RD)通信之后,完全多亏了他们,我把它做成了。我还要感谢 Terry(N4TZ/9),他在九月/十月 NCJ 上的文章描述了改造 DXD 以实现同样的技巧(但用脚踏开关),让我们大家都开始思考这件事。
首先,把 DXD 的跳线(2)置于 CT/Writelog/TR/MM 位置。这会把 LPT 端口的第 5 脚隔离出来。然后在第 5 脚与 DXD 上 S3(即音频模式开关)的 Auto 端子之间接一个 2N2222 集电极开路开关。具体来说,第 5 脚通过一个接在 R22 高侧的 1K 电阻驱动晶体管的基极,就跟基本的 CW 键控接口一样。发射极接到 R22 的接地侧,集电极接到 R29 的开关侧。我用双面胶把晶体管粘在 R22 旁边。难看但有效。就这么简单。
DX Doubler 用在 LPT1 以外的端口上 在 LPT1 以外的端口上使用 DX Doubler 时,请核对正确的地址。 73, Pete N4ZR
West Mountain Radio – RIGblaster
CW 与数字设置 RIGblaster Plus
在 RIGblaster Plus 内部,在 P5 跳线块上设置以下跳线:D9 和 D12,分别对应 PTT 上的 RTS 和 KEY 上的 DTR。把 RIGblaster 所接的端口从 DIGITAL 切换到 OTHER。在 N1MM 的配置中使用 DTR(第 4 脚)设为 CW、RTS(第 7 脚)设为 PTT。采用这种配置,一切都能正常工作,可以从 N1MM 产生 CW;此外,这一组合还能让其他与声卡相关的功能正常工作(MMTTY、SSTV、PSK、Voice Key Express 等)。(作者 David,K1TTT)
CW 键按下不释放问题与 RIGblaster Pro 如果你的电台在 CW 下一直处于键按下状态,试试把 DTR 设为 CW
SSB 设置 RIGblaster Plus
- 串口设置(配置器)
- Com2(任何 com 端口都可以)
- DTR:Always OFF
- RTS:PTT
- 在 RIGblaster 本体上
- 把 Tx/Auto 开关拨到 Auto。
- 音量电平
- 使用你的声卡音量控制
这样设置后,它在发射 wav 文件时能正确地把麦克风静音,而在不发射 wav 文件时 VOX 正常工作。
RIGblaster Advantage
我们有不少用户在设置 RIGblaster Advantage 以实现各种模式时遇到困难。以下内容基于 West Mountain Radio 支持部门提供的信息,但如有任何错误,责任全在我们。
当你把 RIGblaster 驱动安装到计算机上时(我们在此不再记录该过程,因为 Advantage 手册中已有详尽说明),你会在计算机的设备管理器中看到一个新的虚拟 COM 端口和一个新的 USB 音频设备。请记下该 COM 端口的编号
该虚拟 COM 端口可用于使用 RTS 的 PTT、CW 或(使用 DTR 的)FSK 键控,以及电台控制。USB 音频设备(在设备管理器中称为“RIGblaster Advantage Audio”)同时具有播放和录制声道,凡是要求你指定声卡的地方都可以指定它。
从 Advantage 控制电台有两种形式——RS-232C 电平的 DB-9 连接器,以及 TTL 电平的 3.5mm 立体声插孔。TTL 插孔(标记为 CTL IN/OUT)适合控制使用 TTL 电平控制的电台——例如 Icom 的 CI-V 遥控插孔,以及某些 Yaesu 型号上的 8 针 mini-din CAT 插孔。它不适合驱动采用“负 TTL”方式的较旧 Kenwood 电台(如 TS-440S 和 TS-850)。这种情况下你最好的办法是购买或自制一个适配器,把 Kenwood 的控制方式转换为基本 RS-232。
Advantage 的 RS-232 端口可以驱动许多配备 RS-232C 的电台,但有一个前提——收发信机不得要求硬件流控。否则会出现这样的情况:电台把 RTS 拉高,而 Advantage 将卡在发射状态。
许多 Yaesu 电台有一个菜单选项“CAT RTS”,可以将其禁用——这样只需用一根直连串口线连接 Advantage 与收发信机,就能让这些电台的 CAT 工作起来。
FT-847 实际上需要一根空调制解调器线(null-modem cable),但这是 WMR 所知唯一有此需要的电台。由于 FT-847 不要求流控,因此与 Advantage 配合良好。
无法禁用流控的 Kenwood 电台需要一根改装的串口线,在电台一端把 RTS/CTS 短接,以骗过电台,让它以为流控处于活动状态。在我们试过的大多数电台上这都行之有效,但尚未用 N1MM Logger 测试过。更优雅的解决办法是直接使用一根单独的 USB 转 RS-232C 适配器线,这样在 Windows 中会多出一个专用于电台控制的虚拟 COM 端口。在这种配置下,Advantage 的 COM 端口只用于 PTT 和 CW 键控。
Advantage 的前面板上有一个 3 位拨动开关,用来决定 PTT 的处理方式。在“COM”位置,PTT 受 Advantage 虚拟 COM 端口的 RTS 线控制。中间位置“OFF”会禁用经由 Advantage 的 PTT 和 CW。第三个选项是“VOX”,它在语音和数据模式下由使用 AFSK 的音频信号本身导出。
请记住,如果 N1MM 配置为由电台命令进行 PTT,Advantage 无从知道这一点,因此即使电台进入发射,它也不会发射。在串口控制下,务必确保 PTT 由 RTS 完成;如果使用经由电台控制的 PTT,则请使用 VOX 位置。
总之,大多数电台都可以设置 PTT(使用 RTS)和 CW/FSK 键控(使用 DTR)。只要电台有 8 针圆形麦克风插孔或 RJ-45 麦克风插孔,就能工作,因为音频和 PTT 就是这样送到电台的。对许多电台来说,用一根简单的电缆就能实现 CAT。对于配备 RS-232C 插孔且坚持要求流控的电台,使用一根单独的 USB 转 RS-232C 电缆大概更简单。
使用 RIGblaster Advantage 设置 N1MM Logger
现在到了简单的部分。转到 Config > Configure Ports。打开 hardware 选项卡。

选择你将用于电台控制的虚拟 COM 端口号。从下拉列表中选择你的电台。单击“设置”(Set)。不要选择 PTT via Radio Command。确保程序与电台的通信参数一致(参数见电台手册)。如果你能够把同一个 COM 端口用于所有功能(电台控制、CW 和 PTT 都在同一端口上),并且不需要 RIGblaster 自带的 CW/PTT 接口,那么把 DTR 设为 CW、RTS 设为 PTT(如需要),勾选 CW/Other 复选框,就完成了。

要为 CW/PTT 配置 RIGblaster Advantage 的 COM 端口,请选择 Advantage 的 COM 端口并勾选其 CW/Other 复选框。单击 Advantage 的 COM 端口的“设置”(Set)。把该端口上的 DTR 设为 CW,RTS 设为 PTT(如需要)。通常电台需要启用硬件 PTT、电台命令 PTT 或电台自身的 VOX。

变频器(Transverters)
N1MM Logger+ 支持变频器,其形式是可为每个波段图(Bandmap)设置一个偏移频率。右键单击波段图菜单并选择“设置收发信机偏移频率”(Set transceiver offset frequency)。以 kHz 为单位输入收发信机偏移频率(允许为负值)。例如:使用从 28 MHz 到 144 MHz 的变频器时输入 116000(144000 – 28000 = 116000)。其他频段(向上或向下)同理。这可以按波段图分别设置,因此当使用两台配变频器的收发信机时,它们可以各自工作在不同频段上。程序会保存该偏移,因此重启之后偏移仍然存在。
其他硬件信息
全部由 Joe Subich(W4TV)撰写
USB 声卡
以下声卡(按字母顺序)的手册表明它们具有独立的麦克风输入和立体声线路输入。
- Audigy 2NX External
- Creative SoundBlaster MP3+
- Turtle Beach “Audio Advantage Roadie”
下面这个“低价选项”没有在线手册,但网站上的规格显示它分别有麦克风和线路插孔。
- Byterunner UA-580
- 看起来是为需要外置声卡(笔记本等)的人推荐的选择。
其他声卡
- SoundBlaster Live 24 External
- Live 24 External 唯一的问题是麦克风和线路输入不能同时使用(接上麦克风会断开线路输入)。它在 N1MM 中用于内置 DVK 没有问题,但如果你把麦克风环接到 Live! 24 External,就无法同时“录制 QSO”和使用 DVK。
外置声卡与内置声卡
有人声称,对于数字信号,外置 USB 声卡比内置声卡工作得好得多(而且应当使用外置声卡)。
Joe(W4TV):所谓“优势”来自有缺陷的测试,这些测试没有为每个音频设备正确设置输入电平,以充分利用其动态范围。
除了最差的声卡或噪声异常大的系统之外,内置声卡至少有 60 dB 的可用动态范围(较好的 16 位声卡有 80 dB 动态范围,而带高电平输入的 24 位声卡动态范围可接近 100 dB)。如果来自收发信机的音频使接收机噪声底(不接天线)比声卡的噪声底高出六到十 dB,软件 DSP(MMTTY 等)就能全能力工作。接收机 AGC 等会把接收机输出限制在远低于声卡输入能力的电平上。大多数接收机从安静的频段到 S9 +40 dB 的接收信号,变化不会超过 30 到 40 dB。声卡性能与内置还是外置无关,关键在于认真注意设置合适的电平,让声卡正常发挥作用。
不支持的硬件 – W5XD MultiKeyer
W5XD MultiKeyer 不受支持,也没有支持的计划。SO2R 支持由声卡和 Winkeyer 提供,或由使用串口和并口的其他外部硬件提供。
N1MM 旋转器控制
N1MM Logger 的旋转器控制可通过以下方式支持
- 外部软件
- N1MM Rotor(随 N1MM logger 提供)
- PSTRotatorAZ(由 Codrut Buda – YO3DMU 开发,15 欧元/US$22)
- 外部硬件
- EA4TX 出品的 ARSWIN
- Rene Schmidt DF9GR 出品的 ERC 和 ERC-M – ERC-M 控制两台旋转器需要 PSTRotatorAZ
旋转器可以通过几种不同的方式控制:
-
录入窗口(Entry Window):
- 在呼号字段中输入天线方位并按 Alt+J。旋转器会转到所输入的天线方位
- 例如:234 Alt+J 会把旋转器转到 234 度
- 数字必须为数值,❯= 0 且 ❮= 360
- 使用工具菜单(Tools)中的菜单项
- 转动旋转器(Turn Rotor)Alt+J – 把旋转器转到录入窗口中呼号的方位
- 停止旋转器(Stop Rotor)Ctrl+Alt+J – 在旋转过程中且录入窗口呼号字段中没有方位时停止转动旋转器
- 使用下面的快捷键:
- Alt+J – 把旋转器转到录入窗口中呼号的方位,或(当呼号字段为空时)转到呼号框中呼号的方位
- Alt+L – 把旋转器转到录入窗口中呼号的长路径方位
- Ctrl+Alt+J – 在旋转过程中且录入窗口呼号字段中没有方位时停止转动旋转器
- 在呼号字段中输入天线方位并按 Alt+J。旋转器会转到所输入的天线方位
-
波段图窗口:右键单击某个台情并选择:‘转动旋转器’
-
可用系数与 Q 窗口(Available Mult's and Q's window):右键单击某个台情并选择:‘转动旋转器’
-
N1MM Rotor 独立程序
一些说明
- 如果录入窗口的呼号字段中的呼号少于三个字符,则不会发生任何事。
- 状态栏会显示它将转到的方位。例如:转动旋转器至 123 度(Turning Rotor to 123 degrees)
- 通常,输入呼号后旋转器会转向该国家的方位。此信息来自国家文件,大多是该国家的中心。但在网格方格比赛中这通常不实用,因此输入网格后,旋转器会转向本台网格与所输入网格方格之间计算出的方位。
旋转器控制基础
N1MM Rotor 能够控制每个台站最多 16 台旋转器,并能控制连接到局域网中其他计算机的旋转器。除非使用外部接口软件,否则每台旋转器都需要自己的 COM 端口。N1MM Rotor 利用天线选项卡来定义你在某个频段时控制哪些旋转器。N1MM Rotor 甚至可以用一条命令转动一个天线堆。N1MM Rotor 是一个外部程序,既可以在 N1MM Logger 内使用,也可以作为独立程序使用。

支持的旋转器类型
- DCU1 – 不支持停止按钮。
- M2 Orion – 速度显示在状态栏右下方。
- Prosistel
- AlfaSpid
- Yaesu
- RC2800P-A
- Rotor-EZ
- AlfaSpid ROT2
- Prosistel C
- Green Heron RT-21(使用 DCU-1 选项或 Rotor-EZ 设置)
| 除 DCU1 外的所有旋转器都支持位置报告。值得对其他使用 DCU-1 协议或其超集的旋转器尝试 Rotor-EZ 设置,因为天线位置可能会在旋转器窗口(Rotor window)中报告。 | | --- |
上方窗格:上方窗格显示所选旋转器(按工具下设置中的输入)以及 @ 之后的当前旋转器位置。
菜单栏:显示文件(File)、工具(Tools)和帮助(Help)菜单。
大号数字表示当前旋转器位置。如果输入了天线偏移,它会以小号数字显示在当前旋转器位置的右侧。 再往右是指示旋转器指向的图示。对于支持位置报告的旋转器,可以拖动圆圈中的线来转动旋转器。 文本框是一个输入字段,你可以在其中输入旋转器要转到的方位。 单击转动(Turn)按钮会把旋转器转到该位置,而停止(Stop)按钮会在当前位置停止转动旋转器。 反向偏移会显示为 (R) 。
状态栏:显示旋转器报告的速度。
转动时程序会置顶显示(除非已最小化)
文件菜单选择项
- 文件(File)
- 总在最前(Always on Top) – 选择以使程序始终置顶
- 退出(Exit) – 退出程序
- 工具(Tools)
- 设置旋转器(Setup Rotors) – 将显示一个名为“Rotor Setup”的对话框,如下所示

- 设置当前天线偏移(Set Current Antenna Offset)
- 偏移在配置器的天线选项卡上输入,也可以为所选旋转器单独输入。该偏移会加到旋转器位置上以确定天线位置,因此当偏移天线相对于旋转器方向顺时针旋转时,应以“-”号输入。这对于因方向图干扰原因而按 90 度安装的天线,或经过一个冬天被风吹得有所偏移的天线很有用
- 设置当前天线双向性(Set Current Antenna Bidirectionality)
- 双向适用于偶极天线,或用户希望把天线反向而不是转过 180 度以上的 SteppIr 天线
- 校准旋转器(Calibrate Rotor) – 校准旋转器。仅在旋转器支持时可用,如 M2 Orion。ERC/ERC-M 硬件在固件中完成校准。
- Prosistel C 配置(Prosistel C Config)
- 会打开一个对话框,你可以在其中把旋转器停止位置设为北或南,以及设置字符延迟
- 设置转动限位(Set rotation limits)
- 此功能面向使用会卡住的制动器的旋转器用户。你可以输入一个数字,用以限制旋转器转到距 0 或 360 度多近。如果输入 10,限位就是 10 到 350 度。请注意,这只能对程序某个实例所处理的所有旋转器统一设置。把它加到天线选项卡上似乎不值得
- 已设置的每台旋转器都会显示一行
- 每一行代表一台按工具下设置中的输入配置的旋转器
按钮与鼠标分配
-
手动输入字段(Manual entry field) – 输入一个方位并按 Enter 或转动按钮来转动旋转器。输入的数字以度为单位。
- 最大值为 450,最小值为 0。如果输入其他值,按下转动按钮时会出现错误消息。
-
转动(Turn) – 单击可把旋转器转到文本框中的方位。如果输入焦点在 N1MM Rotor 上,按 Enter 也会转动旋转器。
-
停止(Stop)Alt+S – 按下可停止旋转器转动。按 Alt+S 或 Escape 也会停止转动旋转器。
- 只有当旋转器支持此功能时才会显示该按钮。
-
F1 – F10 – 按下映射到方位按钮的 F 键会把旋转器转到按钮上所示的位置。右键单击可设置方位值。
-
方位按钮(F1 – F10)
- 单击鼠标左键
- 按下其中一个方位按钮会把旋转器转到按钮上所示的位置。
- F 键 F1 到 F10 映射到 10 个方位按钮。
- 单击鼠标右键
- 把按钮设为当前位置
- 将使用手动输入字段中输入的方位来设置位置。
- 把按钮设为特定方位
- 会出现一个对话框,可以输入一个方位,用它来设置位置。
- 把按钮设为当前位置
- 单击鼠标左键
只有报告位置的旋转器才能显示当前位置(转动过程中也能显示)。
把旋转器位置信息发送给 N1MM Logger
默认情况下,N1MM Rotor 只把位置信息发送给与 N1MM Rotor 运行在同一台计算机上的 N1MM Logger 主程序。如果你只使用一台计算机,N1MM Rotor 和 N1MM Logger 都运行在该计算机上,你可以跳过本节余下的内容;但如果 N1MM Rotor 与 N1MM Logger 运行在不同的计算机上,就需要继续读下去。
如果你想向运行在其他计算机上的多个 N1MM Logger 副本发送位置信息,就必须用文本编辑器手动编辑 N1MMRotor.ini 文件,以告诉 N1MM Rotor 要把信息发送到哪些计算机。请在 [Rotors] 节中查找“RotorReportingIP”这一行;如果它不存在,你就必须自己添加。
如果网络中的所有计算机都在同一子网内,即它们的 IP 地址都以相同的前三个数字开头(例如 192.168.1.xxx),那么只需把 RotorReportingIP 设为广播 IP 地址(最后一个数字 = 255),就可以把位置信息从 N1MM Rotor 发送到网络中的所有计算机,如下所示:
[Rotors] RotorReportingIP=192.168.1.255
如果你只想把位置信息发送给网络中某些选定的计算机,可以指定一个或多个单独的 IP 地址,用空格分隔。例如:
[Rotors] RotorReportingIP=127.0.0.1 192.168.1.10 192.168.1.12
这样就会把旋转器位置信息从 N1MM Rotor 发送给运行在三台计算机上的 N1MM Logger:运行 N1MM Rotor 的那台计算机本身(无论它位于哪个子网,始终用 127.0.0.1 表示),以及另外两台计算机,在本例中的 IP 地址为 192.168.1.10 和 192.168.1.12。网络中地址未在 N1MMRotor.ini 文件中指定的其他计算机将收不到旋转器位置信息。这些 IP 地址不必都在同一子网内,但它们当然都必须能从运行 N1MM Rotor 的计算机访问到。
独立使用 N1MM Rotor
用 Windows 资源管理器进入 N1MM 程序目录,找到‘N1MMRotor.exe’。这就是 N1MM Rotor 程序。在桌面上创建快捷方式是启动该程序的简便方法。上面提到的所有功能都可以使用。
配合 N1MM Logger 主程序使用 N1MM Rotor
像前一节所示那样,使用 N1MM Rotor 独立程序配置你的旋转器。确认旋转器工作正常。
N1MM Logger 主程序能够从录入窗口转动旋转器。要在 N1MM Logger 主程序中配置这一能力:
- 在配置器中设置天线选择;选项卡:Antennas
N1MM logger 设置对话框位于 >Config >Configure Ports,Antennas 选项卡

在配置器 Antennas 选项卡的 Rotor Description 中输入的字母数字名称,必须与在 N1MM Rotor 设置表单中输入的字母数字名称完全相同。
N1MM Logger 主程序还能显示控制台站所使用的任何旋转器的当前方向,或网络中任何旋转器的当前方向。要配置这一能力,请使用配置器 Antennas 选项卡中的“显示本台站使用的旋转器”(Display Rotors Used By This Station)和“显示来自网络的响应旋转器”(Display Rotors Responding From Network)复选框。每台有响应的旋转器都会出现一个新的显示表单:

启用“显示本台站使用的旋转器”后,只会显示录入窗口中当前活动频段所使用的旋转器。当你更换频段时,所显示的旋转器会自动更新。
启用“显示来自网络的响应旋转器”后,网络中任何 N1MM Rotor 向本计算机报告位置的所有旋转器都会显示出来。
要在 N1MM Logger 主程序内自动启动 N1MM Rotor,请使用配置器 Antennas 选项卡中的“启动 N1MM Rotor 程序”(Start N1MM Rotor Program)复选框。
每部电台一个旋转器——如何实现
偶尔会有人问,在 SO2R 中如何把旋转器与特定电台或 VFO 关联起来——也就是当你在该电台的录入窗口中输入呼号时,控制该电台天线的旋转器能收到命令。
答案很简单——在配置器的 Antennas 选项卡上,把第二部电台的天线定义为某个频段的备用天线,并指定所需旋转器的 COM 端口。然后,在第二部电台的录入窗口处于活动状态时按 Alt+F9。你只需在每次更换第二部电台的频段时做一次。关于为某个频段配置多副天线的更多内容,见此页。
N1MM Rotor 运行在另一台计算机上
假设 N1MM Rotor 位于一台单独的计算机上,其 IP 地址为 192.168.1.14,而你的运行 N1MM logger 的计算机是 192.168.1.10。
- 确保 N1MM Rotor 运行在连接着旋转器的那台计算机上。
- 把这些计算机连成网络。
- 在 192.168.1.10 这台计算机上,进入配置器的广播数据(Broadcast Data)选项卡
- Rotor =127.0.0.1:12040 192.168.1.14:12040
- 在 Antennas 选项卡中启用“显示来自网络的响应旋转器”
- 在 192.168.1.10 这台计算机上,于配置器的 Antennas 选项卡中,每台旋转器都必须在该表中定义
- 在运行 N1MM Rotor 的计算机(192.168.1.14)上的 N1MMRotor.ini 文件中加入以下内容:
- [Rotors]
- RotorReportingIP=127.0.0.1 192.168.1.10
- 通过工具菜单中的菜单项控制旋转器。你把方向或呼号输入呼号文本框,然后按 Alt+J
- 发出请求的台站会看到打开一个旋转器表单窗口,显示旋转器的当前方向。请注意,有些旋转器无法报告进度。
- 你可能需要更改防火墙设置,以允许计算机之间的旋转器通信。
转动天线堆
在上面右侧的示例图片中,天线堆接在 Com3 和 Com4 上,转动天线 4(天线堆)时它们会同时转动。 输入 3,4,所选方位就会发送给旋转器程序,它会告诉 COM3 和 COM4 上的旋转器(无论何种类型)转到该方位角。如果你想控制单副天线,就必须先用主程序中的天线切换(Alt+F9)切换到那副单天线,按 ALT+J,然后再切换到你想要的那组天线。
运行时间错误:126
运行时间错误 126 可能是由防火墙引起的,它不喜欢发给 127.0.0.1 用来通知旋转器程序哪个窗口处于活动状态的 UDP 消息。如果你想在不出现此错误的情况下使用旋转器程序,就需要找出是哪个程序造成了这种干扰。首先检查你的防火墙。如果问题不在那里,有位用户发现一个叫“Port Explorer”的程序是元凶。关闭“Port Explorer”后,问题就消失了。
旋转器 UDP 数据包信息
操作用户选择 >工具(Tools) >转动旋转器(Turn Rotor)(alt+J)时,程序会自动发送广播来操作单独的 旋转器控制(Rotator Control) 程序,无需任何配置设置,也无需修改 N1MM Logger.ini 文件。广播始终在其端口 12040 上发送。开发者备注:旋转器数据包缺少 XML 报头标签,不符合 XML 规范。我们对此心知肚明,也不会去修复它,因为担心会破坏多年前编写的第三方例程。
录入窗口(Entry Window)的 >工具(Tools) >转动旋转器(Turn Rotor)命令会在 UDP 端口 12040 上产生以下 UDP 消息:

N1MM 旋转器数据包
注意 *:频段(freqband)编码的示例有 1.8、3.5、7、14、21、28
录入窗口的 >工具(Tools) >停止转动旋转器(Stop Rotor)(ctrl+alt+J) 命令会在 UDP 端口 12040 上产生以下 UDP 消息:

N1MM 旋转器停止数据包
注意:旋转器既可以用 Rotor 程序设置对话框中显示的名称来指定,也可以用所要控制的串口(COM 口)编号来指定(例如“3”)
单独的 N1MM Rotor 程序在 UDP 端口 13010 上发送的旋转器状态更新消息采用以下格式:
rotorname@rotorheading
外部旋转器硬件与软件
旋转器控制由以下厂商的软件和/或硬件直接支持:
- ARS-USB,由 EA4TX 出品
- PSTRotatorAZ(15 欧元/22 美元,由 YO3DMU 的 Codrut Buda 提供)网址见链接部分。
在尝试控制旋转器之前,请先启动您的 ARS-USB 或 PSTRotatorAZ 软件。
DF9GR 出品的 ERC-M 旋转器控制器可使用单个 COM 口控制方位角-仰角(AZ-EL)旋转器系统或两个方位角旋转器。但是,N1MMRotor 目前不支持这种操作模式。您需要使用两个相互链接的 PSTRotatorAz 实例,在 N1MM Logger+ 与 ERC-M 之间充当中间层。设置有点复杂,但已有完整文档记载,且运行良好。