目录
软件设置
初始安装
本手册的入门(Getting Started)部分详细介绍了程序的下载与安装,见下载软件与安装软件。本节的目的在于说明为多个相互独立的配置设置本程序的高级方法。仅使用一个呼号、且不需要一个以上配置的基础单用户安装用户,不必使用本节所述的方法,而应改为参阅入门部分。
切勿尝试安装程序的多个副本
在同一个操作系统中绝不应安装一个以上的程序副本。本程序及其安装程序使用 Windows 注册表项,这些注册表项只允许存在一个程序副本。程序提供了相应机制,可从单次程序安装支持多个呼号、多种硬件配置,甚至多个 Windows 用户账户。有关这些内容的信息见下文各节。
关于从 N1MM Logger Classic 迁移的说明
与 N1MM Logger Classic 相比,N1MM+ 中的文件结构有所改变。程序本身现在安装在 32 位 Windows 系统的 C:\Program Files 下,或 64 位 Windows 系统的 C:\Program Files (x86) 下,但程序写入的任何文件都不存放在那里。所有用户文件(数据库、ini 文件、错误日志、mc 文件、wav 文件、ADIF 文件、Cabrillo 文件、UDC 文件、呼号历史文件等)都存放在 Logger+ 用户文件区中的专用子文件夹内,该区域默认安装于您个人的 文档(Documents)文件夹中。安装程序允许更改上述任一位置,但建议您不要这样做,直接采用默认值即可(例外情况:如果您的「文档」文件夹通过 OneDrive 或类似系统自动备份,则您可能需要把用户文件区安装到该备份系统无法触及的某处,以避免数据库文件损坏)。
数字引擎文件(MMTTY、2Tone、Fldigi)尚未重写,在 Windows Vista、7、8、10 和 11 中仍需存放在 C:\Program Files 与 C:\Program Files (x86) 路径之外,与使用 Logger Classic 时相同。一种解决办法是让它们保留在使用 Logger Classic 时的原有位置(例如 C:\Hamradio\MMTTY 或 C:\MMTTY 下,或……);另一种解决办法是在您的 N1MM Logger+ 用户文件文件夹内新建一个存放数字引擎的文件夹。两种方法均可。
您现有的 N1MM Logger Classic 消息文件仍可使用。部分例外是 SSB 消息文件,其中 wav 文件的默认位置已经改变;您可以保留旧的 mc 文件,并把 wav 文件在 wav 文件夹中向下多存放一层(即在安装时创建的 wav 文件夹内再创建一个 wav 子文件夹,并把任何操作员专用文件夹放入这个第二层 wav 文件夹中),也可以从旧 mc 文件的文件名中删除开头的 wav\。两种方法均可。
呼号历史文件与 UDC(User Defined Contest,用户自定义比赛)文件也应能顺利迁移。但 Logger 的 ini 文件不会随之迁移(您必须重新进行硬件配置),我们建议您使用 N1MM+ 随附的 Telnet 集群列表。该列表最近已经扩充并重新校验。
多个呼号
如果您将 Logger 用于一个以上的呼号,就应为每个呼号分别建立一个数据库。这包括带有修饰前缀或后缀的呼号(如 W1ABC/3 或 ZL/G4ABC),也包括俱乐部呼号、在比赛中使用自己呼号的客座操作员的呼号,以及使用您的计算机的多操作员台站的呼号。在每个数据库中,请确保台站信息对话框(Station Information)里**呼号(Call)框中填写的呼号,就是该数据库打开时所实际使用的呼号(该对话框可通过配置 > 更改台站数据…菜单项打开)。使用 {MYCALL} 与 * 宏发送的正是该对话框中的呼号;Cabrillo 文件中每条 QSO: 行里出现的已发送呼号也是它。出于日志核对的目的,此呼号必须是实际在空中发送的呼号,而非操作员的呼号(要更改日志中操作员的呼号,请使用 OPON 命令或 Ctrl+O;要在 Cabrillo 文件中更改,请修改该比赛的比赛设置窗口(Contest Setup)中操作员(Operators)**框的内容)。
如果您对同一个呼号使用一个以上的数据库,应注意:当您(通过**文件 > 新建数据库…**菜单项)创建新数据库时,台站信息会从创建新数据库时处于打开状态的那个数据库继承过来。因此,如果您想用自己的某个备用呼号创建多个数据库,可以先切换到使用该呼号的现有数据库,然后再创建新数据库,这样就无需在新数据库中重新输入台站信息。
如果数据库之间唯一变化的是呼号以及台站信息对话框中的相关信息,那么只需使用各自独立的数据库即可。如果您还要针对不同呼号更改硬件配置,则不妨使用下一节所述的多个 INI 文件功能。
ADIF、Cabrillo 与 N1MM Logger+ 中呼号的使用 呼号的使用方式多达三种:作为空中台站标识、作为操作员标识,以及用于标识台站所有者。前两种为 N1MM Logger+ 所使用,并出现在 Cabrillo 文件中的不同位置。第三种通常不出现在 Cabrillo 文件中,但有一种方法可将其添加到文件头的 OPERATORS: 行中。三种都可以出现在 ADIF 文件中,但 Logger 只将前两种导出到 ADIF。
其中最重要的一个是台站呼号,即台站在空中用于标识自己的呼号。这是 ADIF 中的 STATION_CALLSIGN 字段。它就是在 Cabrillo 文件中每条 QSO: 行里作为已发送呼号出现的呼号,也出现在 Cabrillo 文件头的 CALLSIGN: 行中。在 N1MM Logger+ 中,它就是在台站信息对话框(配置 > 更改台站数据…)顶部(Call)框中输入的呼号。它也是您在功能键消息中使用 {MYCALL} 或 * 宏时所发送的呼号。它在数据库中只存储在一个位置,因为对该数据库中的每次 QSO 而言它都应相同。它不会在数据库内的各场比赛之间发生变化。
如果您使用多个台站呼号(例如您自己的呼号以及一个俱乐部呼号或辅助呼号),就应为每一个作为空中台站标识使用的台站呼号分别使用一个数据库。您可以使用**文件 > 新建数据库…**菜单项创建新数据库,并在创建每个数据库时于台站信息对话框中设置台站呼号及其他台站相关数据。
顺带说明,数据库的文件名并不重要。文件名只是 Windows 用来查找该文件的名称。它既不影响文件的内容,也不影响您导出的 Cabrillo 和 ADIF 文件。文件名不必是呼号。如果您愿意,也可以把呼号用作文件名,以便于记住该数据库的用途,但这完全是可选的。
ADIF 文件中的 OPERATOR 字段是在该次 QSO 期间操作台站的操作员呼号。它在多人组中最常用,但在单人组操作员使用俱乐部呼号或辅助呼号时也可以使用。在 N1MM Logger+ 中,它随数据库中的每次 QSO 分别存储,以便在多人组中更换操作员。可以使用 OPON 命令、Ctrl+O 或配置 > 更改日志中存储的操作员呼号菜单项更改它。
如果您从不在 Logger 中更改操作员呼号,它就会与台站呼号相同,您也无需考虑它。但是,只要您曾用上述任一方法更改过操作员呼号,此后它就会在后续 QSO 中被记住,甚至从一场比赛延续到下一场比赛。如果您在多人组中使用某个台站呼号,并让操作员在每次换人时输入各自的操作员呼号,那么在使用同一数据库的下一场比赛中,您所有 QSO 里的操作员字段仍会是在这次多人组中最后操作的那个人的呼号,除非您在多人组结束时或新比赛开始时更改它。
日志中的操作员字段不会输出到 Cabrillo,也许只有文件头的 OPERATORS: 行除外。比赛结束后,如果您愿意,可以使用比赛设置对话框中**从日志更新操作员(Update Ops from Log)按钮,收集该日志中随 QSO 一起存储的所有操作员呼号,并将它们放入操作员(Operators)**框;也可以直接在框中手工键入。
出现在某些 ADIF 文件中的第三种呼号是台站所有者的呼号(OWNER_CALLSIGN)。它很少使用,仅见于以下情形:客座操作员在别台使用自己的呼号作为台站呼号,并希望标识主台;俱乐部台站;或者使用俱乐部呼号作为台站呼号、而操作在某个成员台站进行的情况。N1MM Logger+ 不将此字段导出到 ADIF,但一些通用日志程序会导出。在 Cabrillo 文件中,可以将所有者的呼号作为操作员之一、在其前面加上 @ 字符,从而添加到文件头的 OPERATORS: 行中。
例如,如果 VE3KI 在 VE3FU 的家中台站使用 VA3RAC 俱乐部呼号进行操作,他就应使用一个以 VA3RAC 作为台站呼号的数据库。比赛前,他应使用 Ctrl+O 输入 VE3KI 作为操作员呼号。他会在比赛设置对话框的操作员字段中输入 VE3KI @VE3FU,以便将该信息输出到 Cabrillo 文件的 OPERATORS: 行。Cabrillo 文件头会包含 CALLSIGN: VA3RAC 这一行,Cabrillo 文件中每条 QSO: 行都会以 VA3RAC 作为已发送呼号。Logger 导出的 ADIF 文件会在每个 QSO 记录中包含 <STATION_CALLSIGN:6>VA3RAC 与 OPERATOR:5VE3KI 字段,但所有者的呼号(VE3FU)不会出现在导出的 ADIF 文件中。
多个 INI 文件
N1MM Logger Classic 的老用户可能熟悉一种用备用 .ini 文件启动程序的功能,例如为不同的电台、不同的模式等使用不同的配置。Logger+ 中也有类似功能。您可以将备用 .ini 文件用于不同的屏幕布局与皮肤、不同的硬件,甚至用作调用不同数据库的另一种方法,以替代使用**文件 > 打开数据库…**菜单项。
以下说明假定您进行的是标准安装,程序文件存放在 C:\Program Files (x86)\N1MM Logger+\ 中,可修改的(用户)文件存放在 Documents\N1MM Logger+\ 中。下面给出逐步说明,介绍如何创建两个名为 Radio1 和 Radio2 的新快捷方式(当然,您也可以给它们起别的名字),并使用名为 Radio1.ini 和 Radio2.ini 的新 ini 文件。如果您只想新建一个快捷方式,或者三个,过程完全相同,只需按所需数量作相应更改即可。
首先,在文件资源管理器(File Explorer)中导航到您的 C:\Program Files (x86)\ 文件夹。如果您的系统是 32 位系统,且没有 C:\Program Files (x86)\ 文件夹,则改为转到 C:\Program Files\。无论哪种情况,都在该文件夹内找到 N1MM Logger+ 子文件夹并将其打开。找到名为 N1MM Logger.net.exe 的文件,右击它,在弹出的菜单中选择「创建快捷方式」。在 XP 之后的 Windows 版本中,会弹出一个小窗口,提示「Windows 无法在此处创建快捷方式。是否改为将快捷方式放在桌面上?」。单击「是」——反正您就是要把快捷方式放在桌面上。这样就会在桌面上创建一个名为 N1MMLogger.net.exe – Shortcut 的新快捷方式。右击该快捷方式,在弹出的菜单中选择「重命名」。把名称改为 Radio1(或您想给这个快捷方式起的任何名字)。
至于第二个桌面快捷方式,请重复上一段中的整个过程,只不过在重命名第二个新快捷方式时,将其称为 Radio2(或您想叫的任何名称,只要不与第一个快捷方式或桌面上的其他任何快捷方式重名即可)。
接下来,在文件资源管理器中导航到存放用户文件的 Documents\N1MM Logger+\ 文件夹(注意:如果您的系统中有多个 N1MM Logger+ 文件夹,或者用户文件区曾被移动过,那么您要找的就是帮助 > 在用户文件目录上打开资源管理器菜单项所指向的那个文件夹)。找到名为 N1MM Logger.ini 的文件,右击它,在弹出的菜单中选择「复制」。在文件资源管理器窗口中的其他位置(即显示所有文件和文件夹的区域)右击,在弹出的菜单中选择「粘贴」。这样应会创建一个名为 N1MM Logger – Copy.ini 的新文件(如果已存在同名文件,则可能是 N1MM Logger – Copy (1).ini)。右击该文件,在弹出的菜单中选择「重命名」。把名称改为 Radio1.ini(或您想叫的任何名称)。
同样,对于第二个快捷方式,您需要重复上一段中的整个过程,并把第二个新文件命名为 Radio2.ini(或您想叫的任何名称)。
现在回到桌面,右击 Radio1 快捷方式,在弹出的菜单中选择「属性」。应会打开一个对话框窗口,其中显示快捷方式属性窗格,并且目标(Target:)框中的程序名以蓝色高亮显示。它看起来大致如下:

在该目标框中,把鼠标光标移到最右侧的 “ 的右边、但仍位于文本框内,然后左键单击。这样应会取消蓝色高亮,并让鼠标光标停留在 ” 的右边(如果没有停到您想要的位置,可以用右方向键把光标移到那里)。键入一个空格,然后键入 Ini=Radio1.ini 。如果您为 ini 文件选择的名字中含有空格,则要把文件名本身或整个参数用引号括起来,例如 Ini=”Radio 1.ini” 或 “Ini=Radio 1.ini”。不要在 = 号前后留有空格。单击「确定」。下面的屏幕截图是一个示例,其中桌面快捷方式名为 IC-7800,ini 文件名为 IC-7800.ini 。

再重复一次:对于第二个快捷方式,您要对 Radio2 快捷方式重复上一段中的过程,只不过此时的参数应写为 Ini=Radio2.ini(或您给它起的名称)。
首次使用 Radio1 快捷方式启动程序时,配置将与之前相同,但现在您可以进行只对 Radio1 快捷方式生效的更改(不同的电台、不同的 COM 端口等)。Radio2 也是如此。请注意,尽管各配置可以不同,但它们仍可指向同一个数据库或不同的数据库——这由您决定。您可以通过**文件 > 打开数据库…**菜单项更改数据库,但这只会更改当前桌面快捷方式与 ini 文件所记住的数据库,不会更改其他快捷方式与 ini 文件所记住的。如果两个配置都指向同一个数据库,那么您通过其中一个桌面快捷方式添加到该数据库的任何新比赛或新 QSO,在另一个快捷方式下也同样存在,因为它们使用的是同一个数据库。当您从某个快捷方式首次启动程序时,打开的将是最近从该快捷方式使用过的比赛日志,无论同一数据库中的其他比赛日志是否曾从另一个快捷方式创建和/或打开过。
单台计算机上的多个用户
N1MM Logger+ 将台站呼号及一些相关数据存储在存放 QSO 的同一个数据库文件中。如果您对总体配置满意,但想使用多个台站呼号(例如用俱乐部呼号或特设活动呼号代替您自己的呼号),只需为每个呼号分别创建一个数据库即可,本节余下的内容您大都可以跳过。
另一方面,如果您想为不同的设置使用完全不同的用户文件环境,则可能需要为每个配置分别设置独立的用户文件区。或者,如果您在多用户使用的计算机上安装 N1MM Logger+,并希望保护每个用户的文件不被其他用户访问,那么您可能想了解如何在同一台计算机上、在不同用户账户下为 N1MM Logger+ 设置多种不同的配置。
首先,您需要决定:是让配置之间的差异仅限于由 N1MM Logger.ini 文件控制的项目(简而言之,就是在配置器(Configurer)中设置的硬件配置项、窗口布局,以及程序启动时所使用的数据库与比赛日志的初始选择),还是希望在配置之间有更广泛的差异。对大多数用户而言,前者(N1MM Logger Classic 中就已具备的功能)已经够用。该功能在上一节多个 INI 文件中已有说明。
在最复杂的设置中,您可能希望为使用不同 Windows 用户账户的不同用户设置程序,或者为不同的程序与硬件配置设置不同的用户文件环境。如果只使用一个 Windows 用户账户,无论是多个用户使用,还是单个用户使用不同的程序配置,您都可以在同一个父文件夹内创建多个 N1MM Logger+ 用户文件文件夹。如果涉及多个 Windows 用户账户,每个用户都可以拥有自己独立的 Logger+ 用户文件区,存放在各自的文档文件夹或该用户账户可访问的其他位置。在这种情况下,每个 Logger+ 用户文件区都只能由该特定用户访问。无论哪种情况,在一个 Logger+ 用户文件区中所做的任何更改都不会反映到其他用户文件区中,这包括从硬件配置更改到逐次 QSO 记录的一切内容。如果您想使用多个 Windows 用户账户,但又想让所有用户共享同一个 Logger+ 用户文件区,例如为了把 QSO 记录到同一个共享比赛日志中,也可以使用下文所述的 UserDir= 命令行参数,让每个用户的桌面快捷方式都指向同一个共享用户文件区。请注意,如果您的系统中有多个用户文件区,程序当前使用的始终是帮助 > 在用户文件目录上打开资源管理器菜单项所指向的那一个。
无论您从多少个用户账户运行该程序,程序本身都只安装一次。安装过程是常规的。程序的安装(无论是初始安装还是后续更新)都应从在该计算机上具有管理权限的用户账户进行。
程序文件将安装到程序文件区(在 32 位系统中通常为 C:\Program Files\N1MM Logger+,在 64 位系统中通常为 C:\Program Files(x86)\N1MM Logger+)。Logger 的用户文件区通常就是您希望与首个或主配置一起使用的文件区,默认情况下它通常位于您的文档文件夹中。在 Windows 7 或 8 中,该位置为 C:\Users\[username]\Documents\N1MM Logger+,其中 [username] 是您登录 Windows 所用的用户名。在 Windows XP SP3 中,相应的位置是 C:\Documents and Settings\[username]\My Documents\N1MM Logger+。在 OneDrive 正在、曾经或可能处于活动状态的计算机上,用户文件区的初始安装位置可能在其他地方,例如 C:\HamRadio\N1MM Logger+。
现在,为第二个配置在该配置的使用者有权访问的位置新建一个文件夹。如果该使用者就是您自己,您只需在您的文档文件夹中再新建一个文件夹,并起一个能反映新配置的名称即可。如果该使用者是使用其他用户账户登录您计算机上 Windows 的另一个人,则该文件夹可以是该用户个人文档文件夹中的新文件夹,既可命名为 N1MM Logger+(这样就会由默认的桌面或开始菜单图标调用),也可另起名称以配合自定义的桌面图标使用。
现在,您需要一种方法来告诉 N1MM Logger+ 使用哪个用户文件区。安装程序时创建的原始 N1MM Logger+ 桌面图标,在从安装 Logger 所用的账户运行程序时,会使用原始用户文件区中的配置与数据库文件启动程序;而在从其他账户运行时,则会使用本地文档文件夹中的假定默认位置。如果您想使用自定义的文件区,就需要一种方法来告诉程序改用您刚创建的新用户文件区,而不是默认位置。
在登录到将用来运行该程序的 Windows 账户后,使用 Windows 文件资源管理器在 N1MM Logger+ 程序文件夹中找到 N1MMLogger.net.exe 文件,在 Windows 资源管理器中右击该文件并选择「复制」,然后右击桌面的空白区域并选择「粘贴快捷方式」。这样应会在该用户的桌面上创建一个新快捷方式。
重命名该新快捷方式,以区别于原始快捷方式。为此,右击新快捷方式,选择「重命名」,然后在图标正下方的位置键入能反映您将配合使用的新配置的新名称。
现在再次右击该图标,并在弹出的菜单中选择「属性」。您应会看到一个大致如下的对话框:

在目标文本框中高亮显示的程序名右侧单击鼠标,键入一个空格,然后键入关键字 UserDir= 以及用引号括起来的新文件夹完整路径名,例如 UserDir=”C:\Users\[username]\Documents\[new folder name]” 或 “UserDir=C:\Users\[username]\Documents\[new folder name]”(Windows 7 或 8——在 Windows XP SP3 中,则为 “UserDir=C:\Documents and Settings\[username]\My Documents\[new folder name]”)。UserDir 与 = 之间、以及 = 与文件夹名之间都不得有空格。在下面的屏幕截图中,我把同一路径名(不含 UserDir= 关键字)复制到了「起始位置」(Start in)文本框中;目标文本框不够宽,无法显示其全部内容:

单击「确定」退出属性对话框。新快捷方式现在将使用新文件夹中的用户文件启动程序,而不是使用原始的 N1MM Logger+ 用户文件区。首次运行时,如果新用户文件区为空,程序会像初始安装时那样从头创建一整套用户文件。从新快捷方式打开程序,在台站信息对话框(配置 > 更改台站数据)中输入呼号的任何更改及相关数据,使用文件 > 新建数据库菜单项在新的「数据库」文件夹中新建一个数据库,以存放使用新配置的比赛日志,然后进入配置器进行硬件设置。您可以把其他用户文件(功能键消息文件、呼号历史文件等)从原始用户文件区复制到新用户文件区中的对应位置,以节省设置时间。
从此时起,您可以使用原始的 N1MM Logger+ 桌面图标按第一个配置调用程序,使用新的桌面图标按第二个配置调用程序。实际上,您现在拥有了该程序的两个虚拟副本。您可以运行其中任何一个虚拟副本,但一次只能运行一个——同一台计算机上不能同时运行两个副本。
您可以独立配置这些虚拟程序副本中的每一个;您在其中一个副本中创建的任何新比赛日志,对另一个副本都不可见;您在一个副本中对配置、数据库、窗口位置与布局、皮肤等所做的任何更改,也不会对另一个副本产生任何影响。因此,如果您新增了需要在配置器中更改设置的硬件,就必须在两处都做这些更改。如果您想共享用户数据,例如功能键消息或呼号历史文件,可以在一处进行更改,再把更改后的文件复制到另一个用户文件区中的对应位置。